POODLE: SSLv3 vulnerabilityとfacebook php sdk


“POODLE: SSLv3 vulnerability”で、Facebook Graph APIを使っているサービスの連携がうまくいかなくなった。

対応方法は:

Facebookから提供されている古いphpのsdk (こちらで確認しているのはver3.1.1)を使っていると、base_facebook.php にCURLOPT_SSLVERSION が1ヶ所出てくる。その値を 3 から

に変更すればOK。

FacebookやTwitterとの連携に便利な Gianismとかのプラグインの古いバージョンを使っている場合は、これを確認してほしい。

この投稿へのコメント

コメントはありません。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

この投稿へのトラックバック

トラックバックはありません。

トラックバック URL