net shop adminプラグインを使った多言語化ショップ

Pocket

net shop admin (ネットショップ)とqTranslate X (多言語化プラグイン)を使って、多言語化ショップを開設したい。
現行のver 3.3.6では、qTranslateで言語を切り替えても表記が変わらないので、その対応方法の紹介。
net-shop-admin.php のclass net_shop_admin() のコンストラクタにある

		if ( function_exists('load_plugin_textdomain') ) :
			if ( !defined('WP_PLUGIN_DIR') )
				load_plugin_textdomain('net-shop-admin', str_replace( ABSPATH, '', dirname(__FILE__) ) );
			else
				load_plugin_textdomain('net-shop-admin', false, dirname( plugin_basename(__FILE__) ) );
		endif;

を、net_shop_admin_init() 内にコピペする。それだけで言語切り替えに対応できるようになる。
開発者にも知らせたので、次期versionで対応してくれるかも。

この投稿へのコメント

コメントはありません。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

この投稿へのトラックバック

トラックバックはありません。

トラックバック URL